読者です 読者をやめる 読者になる 読者になる

There's an echo in my head

日々のメモ。

pow+rbenv+bundlerでエラーが出た

"You have already activated json 1.8.0, but your Gemfile requires json 1.8.1. Using bundle exec may solve this."というエラーが出た。

f:id:a2ikm:20131110022334p:plain

Powのwikiを見ると、config.ruでBundler.setupを呼び出すよう書いてあったけど、それでは直らなかった:

# config.ru
require 'rubygems'
require 'bundler'
Bundler.setup

で、PowのほうでもIssueが上がってるけど、Powで使ってるnackのバグらしく、そっちにパッチをあてると直る。PowをHomebrewで入れてる場合はこんな感じ:

$ curl https://raw.github.com/kjg/nack/ff47ca5004b7290ca9c636d71ed43bcf27b5380d/lib/nack/server.rb \
  -o ~/Library/Application\ Support/Pow/Current/node_modules/nack/lib/nack/server.rb

追記 @ 2013-12-09

nack 0.16.0では修正されたみたい*1。powのほうにもpull-requestが上がっている*2ので、近々取り込まれるんじゃないかなあ。

*1:https://github.com/josh/nack/commit/3592127fa828bbfb994e9ec678b23edffcc53585

*2:https://github.com/37signals/pow/pull/424

このブログに出てくるコードスニペッツは、引用あるいは断りがない限りMITライセンスです。